[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Strange L2 failure

On 1/29/2011 10:05 PM, Jack Bates wrote:
> On 1/29/2011 8:47 PM, ML wrote:
>> I just ran into something like this yesterday. A Belkin router with a
>> MAC of 9444.52dc.XXXX was properly learned at the IDF switch but the
>> upstream agg switch/router wouldn't learn it. I even tried to static
>> the MAC into the CAM..router refused.
> That's what really tripped me out, was that the router actually did
> place an ARP entry and pretended like everything should be working.
> Scheduling some more direct tests with packet sniffers next week when I
> get back in the office.
> I'm curious now if IOS has the issue or the line card, so we'll test off
> different cards direct and monitor results.
> Jack

Turns out I ran out of space in the CAM..embarrassing.

What didn't happen was frame flooding.  Since this device was part of 
the ME34xx product line I'd wager Cisco thought it better to drop frames 
than leak data.

I upgraded the IOS to 12.2(50)SE5 from 12.2(25)SEG.  Somehow there is 
more space in the TCAM for unicast MACs between software versions.