[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ale] Cisco VPN on AMD64, Anyone?



If you can get away from Cisco's VPN, I would do so. I have been using 
it for about 10 months now, and it sucks IMO. I had problems accessing 
my local NFS servers after connecting with the VPN. I found that when 
UDP packets are larger than the MTU, they get broken down into multiple 
packets, and they are sent in reverse order. Well the Cisco VPN client 
doesn't like this, so they drop the packets. To work around this I had 
to set the read and write size for my NFS mounts to 1024 for this to 
work. Of couse that made NFS access dog slow. If you have access to 
NFSv4, you could do NFS over TCP, and you shouldn't have any problems 
there. We worked with Cisco on this issue, and they made me a special 
build to allow my NFS to work with higher read/write values, but they 
told me that those changes were not going to go in to the main stream 
code. Also when I connect to my Corporate lan, I can resolve DNS address 
no problem, for about an hour, then DNS resolution quits working for the 
corporate lan. Also, have you run the Cisco VPN on a SMP kernel before? 
All of there docs say that they do not support SMP kernels.I have a SMP 
machine here, but I have never tried it, so I am not sure if it works or 
not.

Denny

Michael Hirsch wrote:

>Has anyone been able to use the Cisco VPN on an AMD64?  It appears to
>have some 64 bit issues.  I'm trying to install Cisco Systems VPN
>Client Version 4.6.00 (0045) Linux Installer on my dual opteron
>Mandrake system and getting 64 bit errors:
>
>make -C /usr/src/linux SUBDIRS=/home/hirsch/Downloads/Cisco/vpnclient modules
>make[1]: Entering directory `/usr/src/linux-2.6.11-12mdk'
>  CC [M]  /home/hirsch/Downloads/Cisco/vpnclient/linuxcniapi.o
>In file included from /home/hirsch/Downloads/Cisco/vpnclient/Cniapi.h:15,
>                 from /home/hirsch/Downloads/Cisco/vpnclient/linuxcniapi.c:34:
>/home/hirsch/Downloads/Cisco/vpnclient/GenDefs.h:101:2: warning: #warning 64 bit
>In file included from /home/hirsch/Downloads/Cisco/vpnclient/Cniapi.h:15,
>                 from /home/hirsch/Downloads/Cisco/vpnclient/linuxcniapi.c:34:
>/home/hirsch/Downloads/Cisco/vpnclient/GenDefs.h:102: error: syntax
>error before "intptr_t"
>/home/hirsch/Downloads/Cisco/vpnclient/GenDefs.h:102: warning: type
>defaults to `int' in declaration of `intptr_t'
>/home/hirsch/Downloads/Cisco/vpnclient/GenDefs.h:102: warning: data
>definition has no type or storage class
>/home/hirsch/Downloads/Cisco/vpnclient/GenDefs.h:111:2: warning: #warning 64 bit
>make[2]: *** [/home/hirsch/Downloads/Cisco/vpnclient/linuxcniapi.o] Error 1
>make[1]: *** [_module_/home/hirsch/Downloads/Cisco/vpnclient] Error 2
>make[1]: Leaving directory `/usr/src/linux-2.6.11-12mdk'
>make: *** [default] Error 2
>Failed to make module "cisco_ipsec.ko".
>
>If anyone has any pointers, let me know.
>
>thanks,
>
>Michael
>_______________________________________________
>Ale mailing list
>Ale at ale.org
>http://www.ale.org/mailman/listinfo/ale
>
>
>  
>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 3190 bytes
Desc: S/MIME Cryptographic Signature