[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ale] Cisco VPN on AMD64, Anyone?



Has anyone been able to use the Cisco VPN on an AMD64?  It appears to
have some 64 bit issues.  I'm trying to install Cisco Systems VPN
Client Version 4.6.00 (0045) Linux Installer on my dual opteron
Mandrake system and getting 64 bit errors:

make -C /usr/src/linux SUBDIRS=/home/hirsch/Downloads/Cisco/vpnclient modules
make[1]: Entering directory `/usr/src/linux-2.6.11-12mdk'
  CC [M]  /home/hirsch/Downloads/Cisco/vpnclient/linuxcniapi.o
In file included from /home/hirsch/Downloads/Cisco/vpnclient/Cniapi.h:15,
                 from /home/hirsch/Downloads/Cisco/vpnclient/linuxcniapi.c:34:
/home/hirsch/Downloads/Cisco/vpnclient/GenDefs.h:101:2: warning: #warning 64 bit
In file included from /home/hirsch/Downloads/Cisco/vpnclient/Cniapi.h:15,
                 from /home/hirsch/Downloads/Cisco/vpnclient/linuxcniapi.c:34:
/home/hirsch/Downloads/Cisco/vpnclient/GenDefs.h:102: error: syntax
error before "intptr_t"
/home/hirsch/Downloads/Cisco/vpnclient/GenDefs.h:102: warning: type
defaults to `int' in declaration of `intptr_t'
/home/hirsch/Downloads/Cisco/vpnclient/GenDefs.h:102: warning: data
definition has no type or storage class
/home/hirsch/Downloads/Cisco/vpnclient/GenDefs.h:111:2: warning: #warning 64 bit
make[2]: *** [/home/hirsch/Downloads/Cisco/vpnclient/linuxcniapi.o] Error 1
make[1]: *** [_module_/home/hirsch/Downloads/Cisco/vpnclient] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.11-12mdk'
make: *** [default] Error 2
Failed to make module "cisco_ipsec.ko".

If anyone has any pointers, let me know.

thanks,

Michael