[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ale] Upgraded and the modem quit working.



I'm tearing my hair out.  Here's the story.  I upgraded to hamm (Debian
distribution  via the
autosh script and grabbed the 2.0.34 kernel and recompiled it.  As far
as I can tell, the modem worked OK after those steps.  I then reviewed
my installed packages and upgraded a bunch of them.  I also installed
diald and tried to configure it.  I couldn't get it to talk to the
modem, so I tried to run pppd manually.  It didn't work.  I then tried
to talk to the modem via minicom.  No response.  Minicom stays
off-line.  It never talks.  I wrote a specialized comm program some time
ago for another purpose and set it up to try to talk to the modem. 
Nogo.  
I've got a pretty full machine and have some problems with IRQs.  I've
got a SB16 PNP card which isn't working on Linux yet, so it may be that
it is interfering somehow, but that doesn't explain why it stopped
working.
The IRQ line  up is:
IRQ     used by
3       PCI ethernet card
4       ttyS0   (on-board serial port)
4       ttyS3  (us robotics ISA modem)
5       SB16
7       lpt
9/2     Dunno, when I boot it says "unknown pci device"
10      SCSI card
etc.

Now I know that sometimes having the same IRQ for two devices can cause
problems, but it used to work.  Besides, I went into the bios and
disabled the ttyS0 (COM1) port to eliminate the possibility.  Nope.  

I have a Cisco IDSN serial control port hooked to ttyS0 and I can talk
to it OK with minicom, so I know serial ports in general are working.  I
also know that there isn't a serious hardware conflict with the IRQ 4
being shared since I can run Win95 and use both serial ports at the same
time with no problems.  If there is a conflict, it's a Linux problem not
a hardware problem.  Besides, when I disabled COM1, COM3 (ttyS2) should
have started working.  \

I've run out of ideas.  I thought it might be setserial so I disabled it
entirely.  Setserial sees the port and correctly identifies it, but I
thought maybe it was putting it in a unusable state, so I did a chmod
000 /bin/setserial (or whatever the path was).  I removed the diald
package so it wouldn't try to diddle the port.  I did a grep for ttyS?
in /etc/ and /etc/init.d to see if something was messing with the port,
but not that I could see.  

The machine is at home and I'm at work, so I can't get a list of
installed packages right now, but there aren't any installed that I can
identify that would affect serial operation.  Does anyone have any
ideas?  What can I try next?  What packages might affect the serial
port?  As far as I can tell, I upgraded most of the base packages (at
least the ones that I had installed) a few admin packages and some in
the libs since some of the packages I installed were dependent on them.

Thanks for any ideas.  

Jim.
-- 
To see my .signature file, go to http://reality.sgi.com/jwl/signature/