[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ale] OT:Maybe, it does involve FC6



On Fri, 2007-04-13 at 09:33 -0400, Scott Castaline wrote:
> Recently I reinstalled FC6 from scratch, after rearranging my HDDs. I 
> noticed that the current hplip version that Fedora has is 1.6.12. When I 
> went to run hp-setup, it would dump out with "error:unable to connect to 
> hpiod" and the same for hplip. It suggested that I restart hplip, which 
> I did several times with no change. Googling only turned up the same 
> feed back and most people were having problems with USB direct connects, 
> mine is networked. I then downloaded hplip-1.7.3 and tried installing 
> that getting the same thing.
> 
> After several hours I installed hplip-1.6.10, which is what I had prior 
> to all this and it worked fine. The hp-toolkit GUI worked fine, for 
> printing, FAXing, and scanning. I liked it because it gave me warnings 
> of low ink. I even tried going through CUPs localhost:631 way to setup 
> the printer. It would allow me to create the printer, but when I went to 
>   do a test print nothing would happen. I deleted it from there and 
> recreated it through the system->admin->printing app. I am able to print 
> but xsane does not "see" it. I would like to get working the way I had 
> it before, through the HP Device Manager, as I think that's why some of 
> the functions aren't working
> 
> Also even though it says that HPLIP-1.6.10 is the version that I've got 
> running, with all of the switching versions, how do I know that bit and 
> pieces of other versions aren't lingering around possibly causing 
> problems. Short of reinstall of FC6 again, which I'm not sure how that 
> would take since I'm now using LVM and I don't want to lose that as I've 
> got about 2 weeks of .flac files (close to 100GB).
> TIA

If you installed using the rpm, you can use rpm -ql hplip to get the
full list of files installed. You can save to a file or pipe it into a
find and see if it's on the machine. Use rpm -e hplip to uninstall it
and run the find again and make sure all files are gone. Then install
the version you want to use.

If you have already removed the rpm package, you can find the file list
of the uninstalled package with rpm -qlp <package name>. Then use the
find...

If you installed from the source tarball, it supports the "make
uninstall" option and will clean out what it installed. But that will
not remove config files it wrote, only binaries. To find out what was
installed, run "make -t install" and it will run the install without
actually writing any files. You will likely need to pipe the output to a
file as there is a load of lines that fly by.

In fact, the rpm -e will leave the old config files behind as
foo.conf.rpmsave files. They will not cause a conflict but serve as a
good reference point.
-- 
James P. Kinney III          
CEO & Director of Engineering 
Local Net Solutions,LLC        
770-493-8244                    
http://www.localnetsolutions.com

GPG ID: 829C6CA7 James P. Kinney III (M.S. Physics)
<jkinney at localnetsolutions.com>
Fingerprint = 3C9E 6366 54FC A3FE BA4D 0659 6190 ADC3 829C 6CA7
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part