[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ale] Touchpad, ipw2200, USB Camera problems on laptop

I can update that the touchpad is an ElanTech touch pad.  Very nice and 
probably just needs a configuration of the buttons.  I think the driver 
problem is a ACPI timing issue.  After a Google search of alot of sites 
and lists, a FAQ for touchpad problems revealed that the mouse driver 
can be prevented from getting it's interrupt by the ACPI modules.  If it 
is delayed too long then it will give the type behaviour I am 
experiencing.  I think ACPI problems are the bane of many Linux 
installations now.

Dow Hurst wrote:
>I have installed SUSE 9.3 on the Compal FL30 laptop. Currently the 
>touchpad is configured as a IMPS/2 Explorer type touchpad on the psaux 
>port. I get a predictable error of the cursor quickly moving to the edge 
>of the screen and activating mouse events with a series of uncontrolled 
>mouse button pushes. Dmesg says an unknown Logitech mouse type 99 when 
>booting the machine. It has a touchpad shown as * with two large buttons 
>shown as X and two small buttons shown as A and B like so:
>The errors happen randomly and the mouse function can be completely lost 
>from X. I've recovered by switching to virtual terminal 1 and rebooting. 
>Lost mouse error events are reported in /var/log/messages when the 
>touchpad acts up. I'm not sure what type of touchpad it is and would 
>like to know the best way to find out. I have the nvidia driver for 3d 
>acceleration working since the laptop has Geforce Go 6200TC video hardware.
>The Intel 2200 wifi worked great after the install. But later, when I 
>switched the interface in Yast2 to "manual control" from "auto 
>configured at boot" so I could turn it on and off when I wanted, then I 
>couldn't turn the interface on. It seems permanently turned off and no 
>MAC address shows in ifconfig eth1. The ipw2200 driver reports that the 
>RF switch is active at boot and the rfswitch file buried in /sysfs for 
>the driver reports the rfswitch=2. I can't find a way to turn the kill 
>switch off such as echoing a 0 or 1 into the rfswitch file under the 
>/sysfs pci bus subdirectory for the ipw2200 driver. I've tried iwpriv to 
>set_power from 6 (OFF) to 0-5 but still I don't get wifi response. The 
>set_power setting seems to relate to powersave modes but doesn't seem to 
>affect the kill switch. There is an external LED and external Mode 
>button on the laptop for the wifi. I haven't had any response from 
>pressing the button that I can tell. I've even deleted the wifi 
>interface in Yast2 and reinstalled/reconfigured but with no change in 
>status. I don't think the ipw2200 driver has control over the kill 
>switch nor does the kernel seem to have a way to control it that I have 
>The USB 2.0 Camera built into the laptop lid is reported by lsusb as a 
>camera device on one of the USB hubs. I would like to know how to access 
>and control the device. Xawtv4 doesn't find the device and neither does 
>There is a multi card reader slot in the laptop I haven't tried out yet 
>for SD and MMC type cards.
>The laptop is definitely a newer Compal that is just rebranded as a 
>Intrex laptop (http://www.intrex.com/pcs/Notebook.aspx). Chem USA 
>(www.chemusa.com) advertises it as the Sonoma Whitebook 2030 if that 
>helps. It has the Intel 915GM chipset with a Pentium M CPU. I like this 
>laptop alot and would like to mainly get the touchpad stable and the 
>wifi back on. The camera would be nice to control but isn't the most 
>important item. The other items like the firewire port and PCMCIA slot 
>are reported properly and configured.
>BIOS info:
>Insyde Software MobilePRO BIOS Version 4.20.10
>EFL30/31 BIOS Version V1.03
>Pentium M 1.86GHz
>1.31GB RAM
>Insyde ACPI BIOS Initialized Version 4.20.09
>Dmesg mouse info:
>logips2pp: Detected unknown logitech mouse model 99
>input: ImPS/2 Logitech Wheel Mouse on isa0060/serio4
>and later in /var/log/messages
>psmouse.c: Wheel Mouse at isa0060/serio4/input0 lost synchronization, 
>throwing 2 bytes away
>psmouse.c: issuing reconnect request
>logips2pp: Detected unknown logitech mouse model 99
>psmouse.c: failed to reset mouse on isa0060/serio1
>input: PS/2 Generic Mouse on isa0060/serio1
>psmouse.c: failed to enable mouse on isa0060/serio1
>psmouse.c: Bad data from KBC - timeout
>I'll be happy to post more info from dmesg, /proc, and /sysfs if 
>requested. Any thoughts or ideas on how to address these issues? Thanks 
>for your help,
>Ale mailing list
>Ale at ale.org