[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ale] ethernet switch doesn't work

Wandered Inn wrote:
> Jeff Hubbs wrote:
> >
> > Are you saying that everything worked with the two different hubs, but
> > not when this new switch is put in place of one of them?
> Yes.  I first replaced an existing hub that has 3 computers, 2 100baseT
> and 1 10baseT.  It did not work.  I then replaced a different hub that
> has just two machines, both 100baseT, still did not work.  The proper
> leds light, but I get the no route message when attempting to ping or
> telnet to another machine through the switch.
> > Are you
> > (mis)using an uplink port, or is a port that you're using accidentally
> > switched to being an uplink port?
> Port 1 can be used as either, there's a switch to set the port use.  I
> even attempted not using that port, assuming that maybe the switch was
> defective.
> >
> > Tried power-cycling both the new switch and the remaining connected hub
> > while they are wired up in the desired fashion?
> I tried power-cycling the switch, not the remaining hub.  In each case I
> attempted to access a machine from another machine on the switch in
> which the connectivity would be through the switch.  I don't think the
> other hub would come into play.
> >
> > FWIW, I've been using a D-Link DSS-5+ 10/100 Fast Ethernet Switch II
> > with joy over most of the last year.  Boy have I ever been glad I popped
> > for a 10/100 switch instead of a hub.
> That was my expectation, but I may have been bitten by the 'you get what
> you pay for' bug.  I cheap sohoware 10/100 autosensing switch.  No
> useful info on their web site either.  Sorry support there.  There's an
> 800 # I'm going to call in the morning to see what assistance I might
> get.  Right now, I'm planning to return it for my $$ unless I get
> resolution via the phone, or someone has any ideas as to what is wrong.

<SWAG alert>

What does "route -n" show when the switch is installed? How about
(I expect they will be identical, but it can't hurt to be sure.)

What does "arp -n -a" show, with and without the switch installed?

You might try installing "snort" <http://www.snort.org> on a machine
connected to the switch and post the output of "snort -v -i eth0" while
doing a ping through the switch. Do this after rebooting the machine.

% snort -v -i eth0 > snort.out 2>&1 &
% ping <some other machine connected to the switch>
<wait a few seconds>
% mail ale at ale.org < snort.out

-- Joe

-- Joseph A. Knapka
"If I ever get reincarnated... let me make certain I don't come back
 as a paperclip." -- protagonist, H Murakami's "Hard-boiled Wonderland"
// Linux MM Documentation in progress:
// http://home.earthlink.net/~jknapka/linux-mm/vmoutline.html
* Evolution is an "unproven theory" in the same sense that gravity is. *
To unsubscribe: mail majordomo at ale.org with "unsubscribe ale" in message body.