[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ale] Stumped on analog audio output



Feeling really dumb here. Must be something simple.

Installed a new 4TB HDD into a miniPC over the weekend. Previously, it had an
MBR HDD, so a new install was needed - GPT on BIOS MB.  Couldn't just backup and
restore or dd everything.

Ubuntu Server 12.04.4 + LXDE + XBMC - same before and after the new install.

Anyway, that box runs Plex Server and XBMC. Before the HDD change, audio over
HDMI and analog worked perfectly. Now I'm unable to get anything but background
static from the analog output. Haven't tested the HDMI audio - it is a hassle.

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: SB [HDA ATI SB], device 0: ALC887-VD Analog [ALC887-VD Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: SB [HDA ATI SB], device 1: ALC887-VD Digital [ALC887-VD Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Generic [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Shows the hw:0,0 is the device I want. That is set in xbmc.  Also tried to play
a WAV file using aplay - no sound.  Tried using mplayer - no sound.

Checked the levels using alsamixer ... turned them up to 100%. No help.
Don't think pulse is installed - so that isn't screwing things up.
$ dpkg -l |grep pulse
ii  libpulse-mainloop-glib0    1:1.1-0ubuntu15.4                PulseAudio
client libraries (glib support)
ri  libpulse0                  1:1.1-0ubuntu15.4
PulseAudio client libraries

Also verified the jack from the PC to the receiver was working. Van Halen still
rocks even from a phone as source.;)

Any ideas? It must be something simple.