[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ale] Trying to use ATI Radeon On-Board Video



On Mon, Nov 30, 2009 at 8:43 AM, James Sumners <james.sumners at gmail.com>wrote:

> Make sure you have the ATi drivers installed that you would like to
> use. The open source ATi drivers are quite good since ATi released
> open documentation for their cards. The open source drivers even have
> 3D acceleration support, and Kernel Mode Setting (in the newest
> drivers). The proprietary driver has faster 3D acceleration, but is
> still garbage IMHO. If you switch between X and VTs frequently, then
> the driver _will_ crash your system so hard that you have to reboot.
>
> In any event, take a look at [1] and [2]. You might start by `mv
> /etc/X11/xorg.conf /etc/X11/xorg.conf.backup` and then `Xorg
> -configure`. Then you can do tweaks by hand based on the information
> in those two links.
>
> [1] -- http://wiki.archlinux.org/index.php/ATI
> [2] -- https://help.ubuntu.com/community/RadeonDriver
>
> On Sat, Nov 28, 2009 at 7:28 PM, Marc Ferguson <marcferguson at gmail.com>
> wrote:
> > Hey Folks,
> > How can I configure my x server via the terminal? Here's some background.
> > My PCI Express card (nVidia GeForce 8600 GT) died last week so I've
> resorted
> > to using the on-board video port. My motherboard is a Biostar TA690G AM2
> 5.x
> > and their site says that it's an ATI Radeon 1200 series port. Ironically;
> I
> > can load into my Windows partitions (Windows Vista: Home Premium) fine...
> > and I can even play video games (Battlefield 2, Star Wars Galaxies,
> etc). My
> > main concern, though, is the Linux partition. I can't seem to setup the
> > right xorg.conf configuration. To be honest, I'm not that great in
> > configuring x via the terminal. I've tried "Xorg -configure" as suggested
> by
> > the Xorg site, but that doesn't work. I tried replacing the old "nv"
> entry
> > with "ati", but that didn't work.
> > The result is the monitor is very pixelated and I can't navigate or
> really
> > see where I am. I can see my mouse, but it's pretty much useless. Once I
> > "startx" the x server, I can't Alt+Ctrl+Backspace back into the terminal.
> I
> > have to do a reboot into runlevel 3 and try again. Thanks for any help.
> > http://www.biostar.com.tw/app/en/t-series/introduction.php?S_ID=17
> >
> > --
> > Marc Ferguson
>
>
> --
> James Sumners
> http://james.roomfullofmirrors.com/
>
> "All governments suffer a recurring problem: Power attracts
> pathological personalities. It is not that power corrupts but that it
> is magnetic to the corruptible. Such people have a tendency to become
> drunk on violence, a condition to which they are quickly addicted."
>
> Missionaria Protectiva, Text QIV (decto)
> CH:D 59
>
> _______________________________________________
> Ale mailing list
> Ale at ale.org
> http://mail.ale.org/mailman/listinfo/ale
> See JOBS, ANNOUNCE and SCHOOLS lists at
> http://mail.ale.org/mailman/listinfo
>

I got a couple of suggestions to try Fedora 12 LiveCD and see if the video
works. So; I did and it worked... even Compiz. So; I backed up my $HOME and
installed Fedora 12. So; problem solved. :)

-- 
Marc Ferguson

www.fergytech.com
www.digitalalias.net

"When life gives me lemons... I make Linuxaide, hmm good stuff!"
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.ale.org/pipermail/ale/attachments/20091203/832837cc/attachment.html