[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ale] glibc Building Help :-(



Hey there guys... I apologize about the length ahead of time...

I'm wondering if anyone here actually has been able to build a glibc,
successfully.  I have been trying now for a little while, and using as
much documentation as I can find from Googling around.  I am fairly
certain that it's the pickiest thing that I've ever tried to build, and
I know that way back when 2.0 reigned supreme (or was it 2.2?), I'd
built a working copy for something I was working on doing.

Well, here I am trying to build one now, and it's failing.  Miserably.
Every time, and no matter what configure options I use.

I compiled a toolchain for this build, since I want everything for i686,
since that's what's running and it's more efficient to tune to the
processor family as much as possible.  I built binutils and gcc without
any problems (after a couple of attempts and a bit of research, my how
things have changed since the 2.7.2.x days...) and those now work.
However, I want to build glibc to match, and I can't get it to happen.
When I do so, I use the following configure:

../glibc-2.3.5/configure --prefix=/tools --disable-profile \
	--enable-add-ons --enable-kernel=2.6.13 \
	--with-binutils=/tools/bin --without-gd \
	--with-headers=/tools/include --without-selinux \
	--with-kernel-headers=/tools/include/linux

Which configures the package successfully without warnings or anything.
 The headers in /tools/include/linux come from (at this particular
moment) the 2.6.13 kernel, and I have --enable-kernel=xx.yy.zz match it,
no matter what version it is.  I've used various kernel versions from
2.6.0 to the current 2.6.13.  No matter what, the build fails when it
gets to "bootparam_prot.T" with the error "FATAL: Kernel too old".  I
have trouble believing that a kernel that was released yesterday is too
old... so I don't understand what the problem is.

The flags to configure come from everything that I've found thus far on
Google, other then some of the ones like where I want the thing placed
when installed and all of that.  I would think that if the kernel was
too old that configure would detect this and bail, but from what I've
found, I see that a lot of people have had the same problem, but I have
not found a solution that works in this case... I have changed various
configure flags, adding and subtracting as I find new things, and
nothing works -- I get the same result.

So.  Does anybody see anything that is wrong with the picture that may
be interfering with this entire process, and preventing me from
successfully building this?  I've tried building glibc now, nearly 100
times in the past week, and with varying options, but always the same
failure.  It's getting me pretty frustrated.

Just to avoid some of the really basic questions:

	- It's not permissions, because I'm running everything under my
	  user account:  Everything from extracting the archives to
	  'make install'.
	- The build fails at exactly the same point, same file, every
	  time, without fail.
	- No ccache, distcc, or non-standard (read: non-GNU) tools are
	  being used to build this.
	- The failing line is below.

	Thanks!

	Mike

CPP='gcc -B/freenix-tools/bin/ -E -x c-header'
/home/fd0man/freenix/build/glibc/i686-pc-linux-gnu/elf/ld-linux.so.2
--library-path
/home/fd0man/freenix/build/glibc/i686-pc-linux-gnu:/home/fd0man/freenix/build/glibc/i686-pc-linux-gnu/math:/home/fd0man/freenix/build/glibc/i686-pc-linux-gnu/elf:/home/fd0man/freenix/build/glibc/i686-pc-linux-gnu/dlfcn:/home/fd0man/freenix/build/glibc/i686-pc-linux-gnu/nss:/home/fd0man/freenix/build/glibc/i686-pc-linux-gnu/nis:/home/fd0man/freenix/build/glibc/i686-pc-linux-gnu/rt:/home/fd0man/freenix/build/glibc/i686-pc-linux-gnu/resolv:/home/fd0man/freenix/build/glibc/i686-pc-linux-gnu/crypt:/home/fd0man/freenix/build/glibc/i686-pc-linux-gnu/nptl
/home/fd0man/freenix/build/glibc/i686-pc-linux-gnu/sunrpc/rpcgen -Y
../scripts -h rpcsvc/bootparam_prot.x -o
/home/fd0man/freenix/build/glibc/i686-pc-linux-gnu/sunrpc/rpcsvc/bootparam_prot.T
FATAL: kernel too old
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 294 bytes
Desc: OpenPGP digital signature