[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ale] failover planning



So are these routes wrong:

[root at flaky]# routes

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use
Iface
192.168.5.1     *               255.255.255.255 UH    0      0        0
ppp1
10.0.5.1        *               255.255.255.255 UH    0      0        0
ppp0
192.168.2.0     *               255.255.255.0   U     0      0        0
eth0
192.168.2.0     *               255.255.255.0   U     0      0        0
eth1
default         192.168.2.254   0.0.0.0         UG    1      0        0
eth0

On Tue, 2004-11-30 at 18:07, Chris Ricker wrote:
> On Tue, 30 Nov 2004, Christopher Fowler wrote:
> 
> > I've set 1 in all/arp_filter and each interface but the box is still
> > responding.
> > 
> > I even deleted arp tables on my desktop to see if that was the problem. 
> > Maybe I need to set something else?
> 
> Note that the kernel sysctl docs say something like "you must use 
> source-based routing for this to work."
> 
> With default routes, you've got something like:
> 
> ...
> 192.168.2.0      0.0.0.0         255.255.255.0   U         0 0          0  eth0
> 192.168.2.0      0.0.0.0         255.255.255.0   U         0 0          0  eth1
> ...
> 
> on your server, and even with arp_filter enabled on both eth0 and eth1, the
> machine is perfectly correct in sending ARP responses for either
> 192.168.2.120 or 192.168.2.121 out either of eth0 or eth1.
> 
> later,
> chris
> _______________________________________________
> Ale mailing list
> Ale at ale.org
> http://www.ale.org/mailman/listinfo/ale