[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ale] Apache 2.0/PHP seg faults?

I've been trying to get 2.0 and php working with no success.  I actually
have it working on a debian box, but am trying to get it going on my gentoo
box.  No luck.  I've even tried copying conf and php.ini files between boxes.

The problem is the same with Apache 2.0.35 and 2.0.36 using php 4.2.0.
Everything compiles and installs successfully.  When I run it with
./apachectl start, it says it started successfully.  However, it dies almost
immediately after starting with no error messages to stderr or to error_log:

./apachectl start
httpd: Could not determine the server's fully qualified domain name, using for ServerName
./apachectl start: httpd started

$ ps -ef | grep httpd

To get an idea of what might be happening, I ran:

httpd -X -f /usr/local/apache/conf/httpd.conf

Segmentation fault

Error code is set to 139.

A little more investigation led me to comment out the following line from

LoadModule php4_module        modules/libphp4.so

After removing the line, apache starts up just fine.  So, the problem seems
to be with the PHP installation.

I've tried recompiling php with various configuration parameters to no
avail.  I've verified php.ini.  At this point, I'm close to rolling back to
1.3, but thought I'd see if anyone else out there is having similar troubles.


This message has been sent through the ALE general discussion list.
See http://www.ale.org/mailing-lists.shtml for more info. Problems should be 
sent to listmaster at ale dot org.