[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ale] permanent networking solution?




ChangingLINKS.com wrote:
> I have still had no luck getting this to run on startup. It occurred to me 
> that I _normally_ use a user and password to get vncserver to work. 
> If I start my box and do not log in to any account, how is vncserver supposed 
> to know which account vncserver applies to? I am somehow thinking that 
> vncserver cannot startup at boot time - or that I need to somehow specify  
> the user. Any comments? 

You can cause a process to be owned by a particular id by starting it as 
follows:

su userid-that-you-want-to-own-the-process -c "script you want to run"

If you run this from rc, you won't need the user's password since the 
'su' command will be executed by root.

> 
> On Wednesday 20 March 2002 09:19, Kevin Krumwiede wrote:
> 
>>Two ways of doing it:
>>
>>The simple way: Put the command to run it in a script that runs every time
>>the machine starts, like /etc/rc.sysinit.
>>
>>The slick way: Create a /etc/rc.d/init.d/vncserver script based on one of
>>the other init scripts.  Give it a chkconfig header, which is just a
>>commented line or two that chkconfig reads to determine what runlevels and
>>what order to start things in -- see man chkconfig.  Then run
>>'/etc/rc.d/init.d/vncserver start' to start it and 'chkconfig vncserver on'
>>to turn it on permanently.
>>
>>Krum
>>
>>
>>>-----Original Message-----
>>>From: ChangingLINKS.com [mailto:ChangingLINKS.com at bigfoot.com]
>>>Sent: Wednesday, March 20, 2002 12:47 AM
>>>To: Kevin Krumwiede
>>>Cc: ale at ale.org
>>>Subject: Re: [ale] permanent networking solution?
>>>
>>>
>>>Thank you . I tried it out but have not tested it yet. I tried to say
>>>chkconfig --level 2345 vncserver on so that vncserver would
>>>always start on
>>>my computer. Then I reboot. When I run chkconfig --list it shows that
>>>vncserver is on on run levels 2, 3, 4, 5. I also look at the GUI "service
>>>configuration" and it says that vncserver is supposed to start up in run
>>>level 5.
>>>The problem is that when I type ps ax, I don't see vncserver.
>>>Further, when I
>>>try to connect from another machine, it won't connect. When I ssh in, and
>>>start vncserver it starts up as :1 (which means that it was not running).
>>>
>>>Am I doing something wrong here? How do I get vncserver to start up every
>>>time the computer starts.
>>>
>>>On Tuesday 19 March 2002 21:30, you wrote:
>>>
>>>>chkconfig ipchains off
>>>>chkconfig iptables on
>>>>
>>>--
>>>Wishing you Happiness, Joy and Laughter,
>>>Drew
>>>http://www.ChangingLINKS.com
>>>
> 


-- 
Until later: Geoffrey		esoteric at 3times25.net

I didn't have to buy my radio from a specific company to listen
to FM, why doesn't that apply to the Internet (anymore...)?


---
This message has been sent through the ALE general discussion list.
See http://www.ale.org/mailing-lists.shtml for more info. Problems should be 
sent to listmaster at ale dot org.