[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ale] Samba




On Tue, 19 Mar 2002, David Corbin wrote:

> Joe Steele wrote:
> 
> >
> >On Tue, 19 Mar 2002, David Corbin wrote:
> >
> >>I have "hosts allow" for my LAN, but not "hosts deny"
> >>
> >
> >Not being familiar with your LAN -- Is gates.csol.com one of the hosts
> >specifically included with 'hosts allow'?  
> >
> Yes.  my hosts.allow has my class C network in it, and gates has one 
> address from that class C.

I guess a better question would have been:  what does your 'hosts allow'
entry look like?  Any of the following should work: 

hosts allow = 199.233.163.
hosts allow = 199.233.163.0/255.255.255.0
hosts allow = .csol.com

On the other hand, the following would probably fail silently (unless you
had your debug level set high enough):

hosts allow = 199.233.163.0/24

You might check the result of the following:

   testparm gates.csol.com 199.233.163.38

This tests whether a given host-name/address is allowed or denied by your
smb.conf file.  If it comes back saying denied, then there's a problem
with your 'hosts allow' entry. 

If it comes back saying allowed, then the only thing I can suggest is
shutting down samba, restarting it, then trying to repeat your steps to
see if you are still getting the 'Connection denied' log message. 

--Joe







---
This message has been sent through the ALE general discussion list.
See http://www.ale.org/mailing-lists.shtml for more info. Problems should be 
sent to listmaster at ale dot org.