[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ale] Ok, I'm really hosed now.



I haven't really followed this thread but I hope I can help out.

When you boot from the Mandrake rescue CD, can you still see your partitions
with fdisk?  Do you know/remember what all your partitions are and where
they are supposed to be mounted?  If so, you should be able to recover
everything using LILO.  Mount the partitions containing kernel images
somewhere (doesn't matter where) and create a lilo.conf file that specifies
the partitions you want to boot and the kernels *named as they are mounted
on your rescue system*.  Then use lilo -c yourlilo.conf (I think that's the
switch) to set up a new bootloader.

This will get you back into Mandrake.  As for fixing the MBR on your Windows
drive... I am not certain, but I think it always contains exactly the same
thing, i.e., someone with the same version of Windows you're using could dd
their MBR to a file and send it to you... anyone know for sure?

Krum


> -----Original Message-----
> From: mebarker at icomcast.net [mailto:mebarker at icomcast.net]On Behalf Of
> Michael Barker
> Sent: Wednesday, March 20, 2002 10:17 AM
> To: Atlanta Linux Enthusiasts
> Subject: [ale] Ok, I'm really hosed now.
>
>
> Last week I put out a question about a problem I was having with my dual
> boot system.  It seems that I had inadvertantly mangled mbr on my
> windows drive and the suggested fix I received was to do an fdisk /mbr
> to rewrite it.  Well one of the things that I have overlooked that may
> have an effect on the whole scenerio is that I had used  Partition
> Commander to set up initially and this may have re-written mbr in a way
> that fdisk could not fix, because it had no effect on the disk.
>
> What did happen is that I lost my facility to access my secondary master
> 30G drive that contains Mandrake 8.1.  I booted through rescue to
> Mandrake and ran /sbin/lilo.  However, I can not get to lilo when
> rebooting.
>
> Now I have to speculate because this is not my area of knowledge or
> expertise.
>
> I have an older Epox AMD 300 with Award BIOS.  I originally built with a
> 6G Matrox and last spring added a 30G Matrox.  When I installed I had to
> install the Matrox drivers to see all of the drive.  This is what I
> believe fdisk /mbr has hosed.  My dilema is that in order to reinstall
> the install program wants to format the drive but I don't want to lose
> Mandrake and all my data.
>
> The 6G Windows drive can be sacrificed as I rarely use it and have no
> important data there.
>
> Can someone help me to understand the problem and find a solution.  I
> have some ideas as to how to recover but I dont want to confuse any one
> with my illinformed speculation.  So knowledge and understanding is my
> first need.
>
> Michael
>
> ---
> This message has been sent through the ALE general discussion list.
> See http://www.ale.org/mailing-lists.shtml for more info.
> Problems should be
> sent to listmaster at ale dot org.
>


---
This message has been sent through the ALE general discussion list.
See http://www.ale.org/mailing-lists.shtml for more info. Problems should be 
sent to listmaster at ale dot org.