[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ale] VNC over SSH2



I've experienced something very similar, and I discovered that the machine
that I was VNC'ing ON to didn't have a route back to my machine (because I
was changing the gateway (installing a VPN [via Box Toxen/bob at cavu.com]).
It might not be the solution, but make sure that the machine in question
knows how to send packets back to the gateway.  VNC will provide a password
prompt dialog box with one way traffic, but will hang shortly thereafter.

Strange?            Yes!
Why?                I dunno!
Want details?       Contact off list!

Happy St. Pack Tricked's Day!-
-CB



> -----Original Message-----
> From: sangell at nan.net [mailto:sangell at nan.net]
> Sent: Friday, March 15, 2002 8:03 AM
> To: kenzoid at io.com
> Cc: ale at ale.org
> Subject: Re: [ale] VNC over SSH2
>
>
>
> ssh2 8080:192.168.0.4:5800 sangell at mydynamicdns.dyndns.org
>
> I am using 1024 bit RSA key for tunnel and 1024 bit DSA key authentication
> (if memory serves)
>
> Once SSH connects I open web browser and point to http://localhost:8080
>
> I get the Authentication page so VNC and SSH are working but the
> authentication fails.
>
> I have read the FAQ at VNC website, but not a lot of detail, I also have
> O'Reilly SSH The Secure Shell but it only has a single paragraph about VNC
> Forwarding.
>
>
> \_\_\_\_\_\_\_\_\_\_\_/_/_/_/_/_/_/_/_/_/_/
> \_    Steve Angell,  MCSE, CCNA           _/
> \_    MIS Operations Manager               _/
> \_    TSYS Debt Management             _/
> \_    Norcross, GA                                   _/
> \_    Phone 770-409-5570                    _/
> \_    Fax      770-416-1752                   _/
> \/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/\/
>
>
>
>
>                     kkennedy at kenzo
>
>                     id.com (Ken          To:     ale at ale.org
>
>                     Kennedy)             cc:
>
>                                          Subject:     Re: [ale]
> VNC over SSH2
>                     03/14/2002
>
>                     09:40 PM
>
>                     Please respond
>
>                     to kenzoid
>
>
>
>
>
>
>
>
>
> On Thu, Mar 14, 2002 at 03:48:53PM -0500, sangell at nan.net wrote:
>
> > Okay, I have VNC working and have SSH2 working. If I try to connect to a
> PC
> > via Web Browser on LAN VNC works perfectly. If I try over SSH2 I get the
> > logon screen but authentication fails. I have SSH forwarding ports 580x
> and
> > 590x and as I said the login for VNC comes thru but
> authentication fails.
> I
> > am thinking it may have something to do with the encryption but it sould
> be
> > unencrypted again by the time it reaches the VNC host machine. Any
> > thoughts?
>
> Hmmm. I do this almost every day, w/o problems, so I know it
> works. Never had this particular problem. You're connecting vnc to
> your localhost port, correct? Have you reviewed the FAQ for VNC over
> SSH (I'm guessing yes, but it never hurts to ask...):
>
> http://www.uk.research.att.com/vnc/sshvnc.html
>
> What params are you giving ssh when you make the connection (to forward
> the ports)?
>
>
> --
>
> Ken Kennedy          | http://www.kenzoid.com            | kenzoid at io.com
> (See attached file: attud7nv.dat)
>
>


---
This message has been sent through the ALE general discussion list.
See http://www.ale.org/mailing-lists.shtml for more info. Problems should be 
sent to listmaster at ale dot org.