[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ale] boot to new kernel on RedHat



Many thanks to all who answered. I believe the solutions from Eric and Chris
will both work. Although, this is a lot harder than it was when I was running
Slackware. In those days, if you compiled a new kernel you were booting to
that one by default.

Now if I could only get all sound functions working, I would be happy. But
that's another story. Maybe more on that later. Anyway, the 2.2.1 kernel
compiles nicely on RedHat 5.2 without any immediate upgrades. I think the
drivers for PCI sound cards leave a lot to be desired, though.

"Eric Z. Ayers" wrote:

> Jim,
>
> It should be simpler than all of that:
>
> copy /usr/src/linux/arch/i386/boot/zImage to /boot/vmlinuz-2.2.1
>
> then edit /etc/lilo.conf:  e.g.
>
> boot=/dev/hda
> map=/boot/map
> install=/boot/boot.b
> prompt
> timeout=50
> image=/boot/vmlinuz-2.2.1
>         label=linux-2.2.1
>         root=/dev/hda1
>         read-only
> image=/boot/vmlinuz-2.0.36-0.7
>         label=linux-2.0.36
>         root=/dev/hda1
>         initrd=/boot/initrd-2.0.36-0.7.img
>         read-only
>
> When you run /sbin/lilo, you'll see messages:
>
> Added linux-2.2.1 *
> Added linux-2.0.36
>
> The one with the * is the default boot image:
>
> All the stuff about copying the system map isn't *that* important
>
> -Eric.
>
> jim writes:
>  > I have RedHat 5.2, but I just upgraded the kernel to 2.2.1. My question
>  > is: How do I get my system to boot the new kernel? I ran make zdisk,
>  > make zlilo & make zImage. I removed the symlink in /boot and replaced it
>  > with the new vmlinuz. I removed the symlink for System.Map and replaced
>  > it with the version left in the root directory. I modified
>  > /etc/lilo.conf. I ran /sbin/lilo again. After all of this, it still
>  > boots the old kernel unless I insert a boot disk made with the new
>  > kernel image. How do I stop this madness?