[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ale] Can't get above 8bpp in RedHat 5.2



if your video card/monitor combination can actually take 16 bit, you can
add a line in XF86Config (you are using XFree86, right?) to ask it to use
16-bit color as default. The magic word is: DefaultColorDepth. You should
put in the Section "Screen" for your X server in the XF86Config, not under
subsection. Other thing you can do is of course, remove subsections or
comment them out for other color depths.

example:
#the accelerated servers (S3, Mach32, blah)
Section "Screen"
    Driver      "accel"
    Device      "Trio64V2/DX or /GX"
    Monitor     "Compaq V75"
    DefaultColorDepth 16
    ^^^^^^^^^^^^^^^^^^^^
    Subsection "Display"
        Depth       16
        Modes       "1024x768"
        ViewPort    0 0
        Virtual     1024 768
    EndSubsection
EndSection

Hope it helps.


Jerry Yu
----------------------------------------------------------------------------
Systems Engineer	| zyu at tc.net
Premiere Technologies	| 404-262-8544(O)	
Atlanta, GA 30326	| ae.tc.net/dept/engineering/op/public/developer/zyu

On Thu, 28 Jan 1999, Benjamin Scherrey wrote:

> Mike Kachline wrote:
> 
> >         Try xinit -bpp 16. "startx" is just a shell script which
> > essentially calls xinit. If all else fails, try "X -bpp 16". See also
> > the man page for "XFree86".
> 
> xinit returns with xterm complaining about a bad command option -bpp (or --bpp
> when I tried that JIC). However, X -bpp 16 worked! Unfortunately it only gives
> me a grey X screen with a mouse and no menu or xterm or nothing.
> 
> > <snip>
> > > Additionally <ctrl><alt>+ doesn't cycle the video modes either which is
> > > something that I know used to work on one of the boxes.
> > <snip>
> >         This is an option which you can set in your XF86Config file. I
> > think XF86Setup gives you a checkbox to enable/disable this feature. Take
> > a look at the "DontZoom" option within the man page for "XF86Config".
> 
> Well DontZoom seems to have no effect but looking at the man page for XF86Config
> (didn't know config files had man pages!) reveals the DefaultColorDepth setting
> for the Screen section which, when assigned the value of 16, gets me working!
> Still can't toggle resolutions but that's not the main problem!
> 
>     thanx & later,
> 
>         Ben Scherrey
> 
>