[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ale] I don't wanna rebuild AGAIN



Thus spake ari (myo at thy.ml.org):

> first of all, check in the "lost+found" dierctory off that partition, for any
> deletions done by fsck.

There was one HTML text file.

> second, can other files use libX11.so.6?

X works, but xvscan and netscape both fail on this same lib file.

> third, how's the output on `ldd xvscan`?

{0}:dogbert:/root/xv/xvscan-1.81-bin>ldd xvscan
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x40004000)
	libm.so.5 => not found
	libc.so.5 => /usr/local/lib/Backups/libc.so.5 (0x4009b000)
	libc.so.6 => /lib/libc.so.6 (0x4009d000)
	/lib/ld-linux.so.1 => /lib/ld-linux.so.2 (0x2aaaa000)


> 
> 3.5th, locate won't have changed unless you ran updatedb since you rebooted,
> but if ldconfig finds the 6.1, and you can actually sum the file, it should
> be present.

{0}:dogbert:/root>updatedb
{0}:dogbert:/root>locate libX11.so
/usr/X11R6/lib/libX11.so
/usr/X11R6/lib/libX11.so.6
/usr/X11R6/lib/libX11.so.6.1
{0}:dogbert:/root>ls -la /usr/X11R6/lib/libX11.so*
lrwxrwxrwx   1 root     root           13 Sep  6 10:24 /usr/X11R6/lib/libX11.so -> libX11.so.6.1
lrwxrwxrwx   1 root     root           13 Sep  6 10:24 /usr/X11R6/lib/libX11.so.6 -> libX11.so.6.1
-rwxr-xr-x   1 root     root       728519 Jul 29 03:27 /usr/X11R6/lib/libX11.so.6.1

> 
> if you're familiar with gdb or strace (or ltrace), use one or more of them to
> see where things are going wrong.

{0}:dogbert:/root/xv/xvscan-1.81-bin>strace ./xvscan
execve("./xvscan", ["./xvscan"], [/* 26 vars */]) = 0
mmap(0, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40006000
mprotect(0x40000000, 19984, PROT_READ|PROT_WRITE|PROT_EXEC) = 0
mprotect(0x8048000, 1146372, PROT_READ|PROT_WRITE|PROT_EXEC) = 0
stat("/etc/ld.so.cache", {st_mode=0, st_size=0, ...}) = 0
open("/etc/ld.so.cache", O_RDONLY)      = 3
mmap(0, 13885, PROT_READ, MAP_SHARED, 3, 0) = 0x40007000
close(3)                                = 0
stat("/etc/ld.so.preload", 0xbffffa90)  = -1 ENOENT (No such file or directory)
open("/usr/local/RealAudio/libX11.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/local/lib/libX11.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/local/lib/Backups/libX11.so.6", O_RDONLY) = -1 ENOENT (No such file or directory)
open("/usr/lib/libX11.so.6", O_RDONLY)  = -1 ENOENT (No such file or directory)
open("/lib/libX11.so.6", O_RDONLY)      = -1 ENOENT (No such file or directory)
write(2, "./xvscan: can\'t load library \'"..., 43./xvscan: can't load library 'libX11.so.6'
) = 43
_exit(16)                               = ?

> 
> if you wish, you can simply install the package X3323upd.tgz from
> ftp.xfree86.org (you can choose libc5 or glibc2 binaries), or if you want to
> build from the src, you can just build the xc/lib subdirectory, or the
> xc/lib/X11 dir if you want to be specific about things.  to build from the
> src, you only need X332src-1.tgz, not X332src-2.tgz or X332src-3.tgz.  you
> need not use imake from the base subdir (xc/); rather from whatever subdir you
> want to start building from.  theoretically, that should work, but it will
> probably need some tweaking.  if so, do ask... tweaking is one of my
> specialties.

My X works fine though.  I'm downloading all the Updates again and going to
re-install just those.


> 
> ari
> 
> 
> Nomad the Wanderer (nomad at orci.com) said this stuff:
> 
> > Ok,
> >   I just got back from a week of vacation (yeah right).  Anyway, I came
> > back to my 2.1.123 system.  It ran fine for a short bit and then hung.
> > I rebooted.  After a fsck and forced fsck I'm getting this:
> > 
> > {0}:dogbert:/root/xv/xvscan-1.81-bin>./xvscan
> > ./xvscan: can't load library 'libX11.so.6'
> > {0}:dogbert:/root/xv/xvscan-1.81-bin>locate libX11.so.6
> > /usr/X11R6/lib/libX11.so.6
> > /usr/X11R6/lib/libX11.so.6.1
> > 
> > {0}:dogbert:/root/xv/xvscan-1.81-bin>ldconfig -v
> > /usr/X11R6/lib:
> >         .
> > 	.
> > 	.
> > 	libX11.so.6 => libX11.so.6.1
> > 	.
> > 	.
> > 	.
> > 
> > I've compared this file against another machine that's working fine
> > using "sum" and they're identicle.  
> > 
> > Anyone know any tricks?  As I said, I don't wanna rebuild my system 
> > again because of this...
> > 
> > Robert
> > 
> > ---------------------------------------------------------------------------
> > Robert L. Harris                |   You mean you paid
> > Senior System Administrator II  |        MONEY for 
> >   at Great West Life.           \_    Service Pack '98???
> > 
> > http://www.orci.com/~nomad
> > 
> > DISCLAIMER:
> >       These are MY OPINIONS ALONE.  I speak for no-one else.
> > 
> > FYI:
> >  perl -e 'print $i=pack(c5,(41*2),sqrt(7056),(unpack(c,H)-2),oct(115),10);'

---------------------------------------------------------------------------
Robert L. Harris                |   You mean you paid
Senior System Administrator II  |        MONEY for 
  at Great West Life.           \_    Service Pack '98???

http://www.orci.com/~nomad

DISCLAIMER:
      These are MY OPINIONS ALONE.  I speak for no-one else.

FYI:
 perl -e 'print $i=pack(c5,(41*2),sqrt(7056),(unpack(c,H)-2),oct(115),10);'