[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ale] 2Q: (1) H/W - IRQs, (2) S/W - modules



Just replacing my quaint 386/6DX40 ISA with a super whamodyne FCI 2007
with all mod cons, plug in old cards, and it won't play (cdrom, that is;
haven't tried modem yet). Two questions:

(1) I had my cdrom drive at I/O address 0x300, IRQ=10.  On the new board,
its IRQ isn't identified.  Under Win95 my cdrom drive is found, but that
isn't interrupt-driven -- provisional conclusion: smart, new motherboard
has other uses for IRQ10, kills it, or ???  When I change the IRQ to 14,
it hangs the boot -- perhaps conflicting with 2nd IDE.  I also tried
another socket for the adapter (which is ISA, as is the modem). Can
someone suggest an innocuous IRQ for this? (I also have modem at ttyS2,
[meaning COM3:] and mouse at cua1 [meaning COM2:], primary and secondary
IDEs, plus one PCI video card at ???  -- removing the new video card
changes nothing.)  Ideas welcome. 

(2) When I rebuild both kernal and modules (2.0.30 off RH 4.2, with
kernel-source update 'rpm'), I have problems with incompatible module
versions, even when I recopy kernal and rerun lilo.  How do I get the new
set of modules to register correctly, other than 'make modules_install'
which I did?  I have quite likely also trashed the list of modules to
search and/or install, through manual flailing. 

At this point, I'm not thinking too clearly about all this.  Thanks.

 John M. Mills, Senior Research Engineer   --   john.m.mills at gtri.gatech.edu
    Georgia Tech Research Institute, Georgia Tech, Atlanta, GA 30332-0834
          Phone contacts: 404.894.0151 (voice), 404.894.6285 (FAX)
 "The one piece of advice I can give you is, put on sunscreen and wear a hat."
                          -- Ted Turner, GSU Commencement, Atlanta, 1994