[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ale] can't load libdl.so.1



I've been messing with my Linux box and I tried to upgrade my libc library.
 I couldn't get either the binary tar file or the source tar file to
install properly, probably because I'm using gcc 2.7.2.2.f (?).. with g77.

So I thought, fine, I'll just download the rpm versions of libc, but it
won't install because rpm says it needs ld.so.1.8 or greater and I have
ld.so.1.7 (whatever comes with RedHat 4.2).  So I download the latest ld.so
(ld.so-2.0.4-1.i386.rpm) from the gatech mirror.  It also gave me a failed
depends error message but I forced it  's installation by using
--nodepends. OOPS!!

I noticed immediately after forcing the installation that it couldn't see
/sbin, /bin ... so I rebooted.  No good.  So I tried to "upgrade" using my
RedHat 4.2 CD-ROM and boot disk.  I just upgraded all the libs, hoping to
restore the original libraries.  Unfortunately, rpm won't install the
original libdl.so.1 (since a newer one is installed) so I'm stuck with the
latest version which has my computer frozen.

Now, I'm locked out of the Linux side of my computer (I'm writing this from
Win95 side).  When I boot, I get the error message on my boot console,
"can't load libd1.so.1", then I get the login prompt.  But I can't login
because of the failure of this lib to load.  

Finally, I tried rebooting and using the rescue option but it fails when it
tries to remove some tmp or var file which it can't find, and just
hangs....

Anyone have any ideas how to get in and install the original RedHat 4.2
libdl.so.1 lib?  Maybe if I could just force RPM to install the original
libdl.so.1 (even though its "older") during the RedHat "upgrade" session I
might be OK.

Please give me detailed instructions as I'm a newbie (otherwise I wouldn't
be in this mess!)  Thanks.


      __e
  _ `\<,_
(X) /  (X)
Lisa Chiang
gt6492d at gatech.campus.mci.net