[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[ale] Diskless WS (PC)



--------------72CEEDEC50CECD1BEBDB5C45
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit

Needing some help on setting up a diskless workstation. I've read all
the mini-howtos on diskless workstations, NFS-ROOT, and readmes from the
packages suggested, but still can't seem to get it right. Here's what
I've done so far:
Remote PC -
    -  created the boot-disk kernal with tcpip, ethernet card (NE2000),
and NFS support.
    - created the root disk (downloaded specifically for this from
sunsite)
    - modified hosts, bootptab, rc.S, rc.bootp, inetd.conf, rc.inet1,
rc.inet2 with my client ip and host,   and the NFS host information

NFS Server -
    -  compiled a new kernel with NFS and BOOTP support (already had NFS
working before)
    -  modified inetd.conf, services, hosts, export, bootptab, rc.S
    -  created the subdirectories for the remote ws with a, ap, n, x,
and xp

I'm 'fairly' certain I've followed the instructions right, but here's
what happens:
    -  on the server, bootp doesn't seem to be running - I try bootptest
and get
                no response from 192.168.1.1
    -  if I start bootpd with debug on, I get:
bootpd: info(6):   bootptab mtime: Fri Nov 14 01:50:15 1997
bootpd: info(6):   reading "/etc/bootptab"
bootpd: info(6):   read 2 entries (0 hosts) from "/etc/bootptab"
bootpd: error(3):  bind: Address already in use

    -  on the remote PC, on bootup, rc.S gets to Calling bootp.....,
then comes back with
                No response from BOOTP server
        then halts (no keyboard response - have to power cycle)

So, I think I have the remote side set up correctly, but the server side
isn't running BOOTP correctly. Kinda lost now, so anyone else try this
and run into the same problem? Or at least think of anything else I need
to do?

Thanks,
Matt

--
-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-
mailto:mshade at mindspring.com          mailto:mss at atl.hp.com
                            Matt Shade
-----------------------------------------------------------
And God said, "Let there be vodka!" And he saw it was good.
Then God said, "Let there be light!"
And then He said, "Whoa - too much light."



--------------72CEEDEC50CECD1BEBDB5C45
Content-Type: text/html; charset=us-ascii
Content-Transfer-Encoding: 7bit

</pre>
<HTML>
Needing some help on setting up a diskless workstation. I've read all the
mini-howtos on diskless workstations, NFS-ROOT, and readmes from the packages
suggested, but still can't seem to get it right. Here's what I've done
so far:
<BR>Remote PC -
<BR>    -  created the boot-disk kernal with tcpip,
ethernet card (NE2000), and NFS support.
<BR>    - created the root disk (downloaded specifically
for this from sunsite)
<BR>    - modified hosts, bootptab, rc.S, rc.bootp, inetd.conf,
rc.inet1, rc.inet2 with my client ip and host,   and the NFS
host information
<BR> 
<BR>NFS Server -
<BR>    -  compiled a new kernel with NFS and BOOTP
support (already had NFS working before)
<BR>    -  modified inetd.conf, services, hosts, export,
bootptab, rc.S
<BR>    -  created the subdirectories for the remote
ws with a, ap, n, x, and xp

<P>I'm 'fairly' certain I've followed the instructions right, but here's
what happens:
<BR>    -  on the server, bootp doesn't seem to be
running - I try bootptest and get
<BR>               
no response from 192.168.1.1
<BR>    -  if I start bootpd with debug on, I get:
<BR>bootpd: info(6):   bootptab mtime: Fri Nov 14 01:50:15 1997
<BR>bootpd: info(6):   reading "/etc/bootptab"
<BR>bootpd: info(6):   read 2 entries (0 hosts) from "/etc/bootptab"
<BR>bootpd: error(3):  bind: Address already in use

<P>    -  on the remote PC, on bootup, rc.S gets to
Calling bootp....., then comes back with
<BR>               
No response from BOOTP server
<BR>        then halts (no keyboard
response - have to power cycle)

<P>So, I think I have the remote side set up correctly, but the server
side isn't running BOOTP correctly. Kinda lost now, so anyone else try
this and run into the same problem? Or at least think of anything else
I need to do?

<P>Thanks,
<BR>Matt
<PRE>-- 
-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-
mailto:mss at atl.hp.com
                            Matt Shade
-----------------------------------------------------------
And God said, "Let there be vodka!" And he saw it was good.
Then God said, "Let there be light!"
And then He said, "Whoa - too much light."</PRE>
 </HTML>

--------------72CEEDEC50CECD1BEBDB5C45--