[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

LILO



If I understand the follow up here, there is a concern with Linux on a 2nd
IDE harddisk and LILO.  I in fact am running this configuration as I type. :)

This is what I've got:

disc 1 - 850 Meg:
	1st partition 550 Meg M$ windoze 95	(please don't tell anyone, it's
		for work, I did not pay for it, my company did)

	2nd partition 16 Meg. Linux swap.

	The rest unformatted and unpartitioned at this time.

disc 2 - 1.2 Gig:
	1st partition 500 Meg. M$ windoze 3.11 for jerkgroups (please don't
		tell anyone it's for my wife)

	2nd partition, previous 16 Meg swap that is now a 'ittybitty' dos
	partition I created to keep my cdrom drive letter consistant.

	3rd partition ~ 750 Meg. Linux


I installed LILO in the MBR of the first disc and it works great.  I can
boot the OS :), or either primary Micro$oft partitions.  I guess I don't
understand the problem here, sorry I may have missed the start of this
thread.

I'd be curious as to what is on the first disc and what you mean by:

} > I tried installing lilo in the MBR, /dev/hda vs. /dev/hda1 -- to no
} > avail. ............................


} On Fri, 19 Jan 1996, Jeff Haynie wrote:
} > On Fri, 19 Jan 1996, Omar Loggiodice wrote:
} > > I would recommend that you install LILO in the master boot record of the
} > > first hard drive (/dev/hda instead of /dev/hda1), especially given the
} > > fact that you have only linux installed. By installing LILO in /dev/hda1
} > > you are locating it in the _first_ partition, rather than the MBR of the
} > > first disk (/dev/hda).
} > I tried installing lilo in the MBR, /dev/hda vs. /dev/hda1 -- to no
} > avail. Any other suggestions? Reading the fact gives you the reason
} > for 'LIL' but no solutions.
} > Jeff
} Hi Jeff and Omar.  
} I used to run Linux on my second IDE harddisk with no problem.
} I don't know whether there is a way to get LILO boots up on second harddisk
} hassle-free, because I can't get the thing done either.
} 
} So, I gave up and find a work-around.  This is what I had done:
} 
} 1.get 'lodlinux.zip' from somewhere (for me, I had a copy ready)
} 2.install your lodlinux.zip on the DOS partition
} 3.erase LILO bootstrap program at MBR by 'sys a: c:'
} 4.add this line to your autoexec.bat -
}     lodlinux.exe [your parameter to indicate your Linux partition]
} 5.your system will now boot up with DOS and then run Linux smoothly.
} 
} Sorry for the ambigous part on lodlinux, I can't remember the thing.
} This method works fine for me and should do for you providing that
} you have a bootable DOS partition and lodlinux package.
} 
} Choke


       Until later,       attmail!gamyers      ph  404.810.3250
       Geoffrey Myers                          fax 404.810.2487

       floc 6E26, 1200 Peachtree, Promenade II, Atlanta, GA 30309

      gamyers at attmail.com   geof at denali.is.net   eiger at ichange.com