[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

gcc elf/a.out compilation blues



Ok folks. I have been helping a friend, Jeff Waldrop, try to install the
Ga Tech Cthreads package on his Slackware ELF distribution linux machine.

We installed both the ELF and the a.out packagess. I downloaded an a.out 
compiled version of the Cthreads libraries (that I know works because it
works on my a.out old slackware distribution) and tried to do 

gcc mycode.c -L/usr/local/lib -lcthreads

ANd it complained loudly. Its says that it can't find the symbols that are
the Cthreads calls that should be in the Cthreads library.

I suspect that the problem is in getting the system to recognize the different
types of libraries (both a.out and ELF) at the same time. 

I tried recompiling the Cthreads librariess on his machine and got maajor
problems. But this is not surprising since we didn't develop the Cthreads
port on an ELF distribution. 

We are completely stumped. Jeff really wants to use linux to do some work at
home but if we can't do just this then the usefulness of linux for him is
greatly diminished.

Any ideas?

V and Jeff
-- 
Vernard Martin
(vernard.martin at cc.gatech.edu) http://www.cc.gatech.edu/people/home/vernard/
College of Computing, Georgia Institute of Technology, Atlanta, GA 30332