[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Tunnel problems

Hi. I run KFU and have had a tunnel to DIGITAL-CA for quite a while now.

About a month ago, it stopped working. I've traded some mail with the 
admin of DIGITAL-CA, but I wonder if what I'm seeing could explain any 
of this.

I can see packets from the net arrive through the tunnel. If someone 
using 6to4 ping6s me, it actually works, since the packets come down 
through the tunnel, then go back out via 6to4.

But if I send packets out through the tunnel, they never get there. 
traceroute6 doesn't show them making the first hop. traceroute (ipv4) 
with (or without) -P 41 shows that there's nothing wrong with the ipv4 
path between me and the tunnel endpoint.

The only other nodes on the Internet I have access to are 6to4, but I 
did manage to perform one test which puzzled me.

I did a traceroute6 -n quack.kfu.com. Here's what I got:

traceroute6 to quack.kfu.com (3ffe:1200:301b:0:2d0:b7ff:febe:e2a8) from 
2002:xxxx:xxxx:0:xxxx:xxxx:xxxx:xxxx, 30 hops max, 12 byte packets
  1  2002:xxxx:xxxx:0:yyyy:yyyy:yyyy:yyyy  0.333 ms  0.234 ms  0.217 ms
  2  2002:zzzz:zzzz::1  9.925 ms *  9.335 ms
  3  3ffe:3600::9  177.727 ms *  178.057 ms
  4  3ffe:1200:301b:0:2d0:b7ff:febe:e2a8  59.383 ms  26.588 ms  26.058 ms

(I'm obscuring the 6to4 addresses because I don't think it matters where 
on 6to4 this takes place. I've done it from a couple places and got the 
same answer. I even tried traceroute6 -g www.6bone.net quack.kfu.com and 
got the same last-hop).

3ffe:3600::9 is, according to the registry, in Taiwan!

Nevertheless, when I do this, a tcpdump happening back on the LAN at KFU 
shows the packets arriving in their encapsulation from the right IPv4 

Is traceroute6 somehow missing some of the hops between Taiwan and 
DIGITAL-CA? Or does this have to do with the fact that the reply route 
is different from the source route since the source is using 6to4?